Author Topic: Insufficient Memory when testing proxies by EPS  (Read 5791 times)

audiotext

  • Newbie
  • *
  • Posts: 3
    • View Profile
Insufficient Memory when testing proxies by EPS
« on: January 08, 2008, 09:21:35 PM »
I am running XP with EPS professional with 2gb ram.
I have patched my XP so that i can open up to 50 simultaneus connections.
I have set max thread to 40.
If i verify a 2000 proxies list then it's ok and successfull.
If i download a new list of 2000 (over the 2000 already resident on EPS) then i have a total of 4000 proxies stored in my EPS.
At this point i run a full scan again of all 4000 proxies and when i reach around the 60% of the scan, EPS stops scanning and a window appear saying "insufficient memory".
Is it normal?
It only happens when i have to test 4000 proxies (instead of 2000).
I think 2gb ram on my pc are enough to perform this operation!!
What should i do?

audiotext

  • Newbie
  • *
  • Posts: 3
    • View Profile
Insufficient Memory when testing proxies by EPS
« Reply #1 on: January 08, 2008, 09:31:36 PM »
I ve seen a post in another section regarding the crash of EPS during scan due to a bug on old version.
I have no idea if this guy has the same mine problem of "insufficient memory" message.
My EPS in fact doesnt crash, it just stops scanning with that message and nothing else happen.
However, i run the version 1.03, should be the last version.
Maybe it is another bug to be fixed?


Terry

  • Administrator
  • *****
  • Posts: 1669
    • View Profile
Re: Insufficient Memory when testing proxies by EPS
« Reply #2 on: January 09, 2008, 03:30:50 AM »
EPS usually uses about 11MB memory to test 6500 proxies. Maybe it's the problem of your other program.
When the problem happens again, please open your Task Manager to see whether it's EPS.exe that used your 2GB memory.

BTW, EPS 1.04 is release, please download it here:
http://www.eliteproxyswitcher.com/EPS_setup.exe
Elite Proxy Switcher - Easily testing and using proxies.
Socks Proxy Checker - To be your chief socks proxy checker.
Buy Proxy - Buy checked proxies from My-Proxy easily and quickly.

audiotext

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Insufficient Memory when testing proxies by EPS
« Reply #3 on: January 09, 2008, 11:25:00 AM »
I have installed the EPS 1.04
Now i have a total of 3900 proxies.
Started to test all of them, and once reached 67% of the progress, the usual error window appeared saying "insufficient memory to execute the command"
That error window comes from EPS and not from windows xp.
I have max tcp connections sets to 50 (patched) and max thread=40.
I wasn't running any other program, except msn messenger.
I opened task manager during the test process and everything was fine, i had a lot of free available memory and cpu usage was very low.
What's wrong? Another possible bug maybe?


katmando

  • Post Rank: 4
  • ****
  • Posts: 214
    • View Profile
Re: Insufficient Memory when testing proxies by EPS
« Reply #4 on: January 09, 2008, 03:47:32 PM »
For pete sake, the simple solution IS ... don't test so many proxies in one session.  Breakup your list into thirds or fourths ... whatever works best and most efficiently.  No one has 3900 good proxies anyway.

Eliminate the duplicates, the Planetlab/CoDeeN, the so-called "dangerous", the multiple gateway proxies which lead back to the same main server, etc.  That will probably cut your list down considerably ... perhaps by two-thirds.  Once you start to test your smaller list(s) eliminate all the non-working and transparent and you will be lucky if you have 200-300 anonymous.

By the way, EPS has not been programmed to determine the main server of a gateway proxy, but it should.  It should also automatically convert ports 68660 and 68664 to 16-bit 3124, 3127 or 3128 but it doesn't.  These are not bugs, just a lack of (good) programming.
I tell it like it is and that's offensive to those professing knowledge they don't have.

Terry

  • Administrator
  • *****
  • Posts: 1669
    • View Profile
Re: Insufficient Memory when testing proxies by EPS
« Reply #5 on: January 09, 2008, 10:38:35 PM »
Hi audiotext, an email is sent to you.

Here is a temporary solution for you:
After you close the "Insufficient Memory" dialog, righ click the list, click "Delete timeout proxies". Then select all the unchecked proxies and click the "Test" button to only test the unchecked proxies.

Thanks, katmando, good suggestion.
Elite Proxy Switcher - Easily testing and using proxies.
Socks Proxy Checker - To be your chief socks proxy checker.
Buy Proxy - Buy checked proxies from My-Proxy easily and quickly.

 

anything
anything