Author Topic: 3proxy on CentOS 6 (Command: 'proxy' failed with code 40)  (Read 8941 times)

Bio3DDD

  • Newbie
  • *
  • Posts: 1
    • View Profile
3proxy on CentOS 6 (Command: 'proxy' failed with code 40)
« on: May 12, 2016, 03:10:48 AM »
Hello, I have a problem with my proxy.
So, I have a server with 3 IPv4 on it, then I add another ten IPv6.
I'm trying to set up via SSH-client network so that via Proxyfier Proxycap or I could go to the network under different IP sixth version. However, the server notifies an error when I try to run 3proxy:
Quote
[root@evgen177 ~]# service 3proxy start
Starting 3Proxy
 
[root@evgen177 ~]# proxy of 3proxy-0.8.6 (160307165135)
Usage: proxy options
Available options are:
 -u never ask for username
 -u2 always ask for username
 -fFORMAT logging format (see documentation)
 -l log to stderr
 -lFILENAME log to FILENAME
 -b(BUFSIZE) size of network buffer (default 4096 for TCP, 16384 for UDP)
 -S(STACKSIZE) value to add to default client thread stack size
 -t be silent (do not log service start/stop)
 -iIP ip address or internal interface (clients are expected to connect)
 -eIP ip address or external interface (outgoing connection will have this)
 -rHOST:PORT Use IP:port for connect back proxy instead of listen port
 -RHOST:PORT Use PORT to listen connect back proxy connection to pass data to
 -4 Use IPv4 for outgoing connections
 -6 Use IPv6 for outgoing connections
 -46 Prefer IPv4 for outgoing connections, use both IPv4 and IPv6
 -64 Prefer IPv6 for outgoing connections, use both IPv4 and IPv6
 -pPORT - service port to accept connections
 -RIP:PORT - connect back IP:PORT to listen and accept connections
 -rIP:PORT - connect back IP:PORT to establish connect back connection
 -n - no NTLM support
        Example: proxy -i127.0.0.1
 
Service not started on line: 14
Command: 'proxy' failed with code 40, line 14
And this is proxy's config:
Quote
pidfile /usr/local/etc/3proxy/3proxy.pid
nserver 2001:4860:4860::8888
nserver 2001:4860:4860::8844
maxconn 100
nscache 65536
timeouts 1 5 30 60 180 1800 15 60
daemon
setgid 65535
setuid 65535
flush
auth strong
users хххх:CL:ххххх
#allow хххх
proxy -6 -n -a ?p1001 -i91.ххх.ххх.ххх -e2001:ххc:ххх:2::2
proxy -6 -n -a ?p1002 -i91.ххх.ххх.ххх -e2001:ххc:хххc:2::3
And this what "ifconfig" command says:
Quote
[root@evgen177 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 52:54:00:CE:10:06
          inet addr:91.ххх.ххх.ххх  Bcast:91.ххх.ххх.ххх  Mask:255.255.255.0
          inet6 addr: fe80::5054:ff:fece:1006/64 Scope:Link
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          inet6 addr: 2001:ххх:хххх:х::х/48 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3238416 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76990 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:230270948 (219.6 MiB)  TX bytes:4872607 (4.6 MiB)
 
eth0:1    Link encap:Ethernet  HWaddr 52:54:00:CE:10:06
          inet addr:91.ххх.ххх.ххх  Bcast:91.ххх.ххх.ххх  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
 
eth0:2    Link encap:Ethernet  HWaddr 52:54:00:CE:10:06
          inet addr:91.ххх.ххх.ххх  Bcast:91.ххх.ххх.ххх  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
 
[root@evgen177 ~]#
So what is my mistake?

 

anything